Plenty of licensed and some free of cost script-driven apps have encrypted code, that is not human readable. The idea behind this is to stop the reverse engineering and the illegal use of such applications. One of the most popular file encryption instruments used for this particular purpose is named Zend Guard and it is commonly used due to the fact that it can be used to alter all PHP 4 or PHP 5 code. The sole way for the encoded files to run correctly on a web server after that is when an additional tool called Zend Optimizer is present. In case you want to use any type of paid web software which needs Zend Optimizer, you have to make sure that it's installed on the server where you'll host your website. Furthermore, sites which require the tool can perform better due to the fact that their code is already precompiled and optimized, and therefore it's executed more quickly.
Zend Optimizer in Cloud Hosting
If you buy a Linux cloud hosting through us, you have the option to pick the PHP version, that will be active for your account according to what your script apps require. You will be able to activate Zend Optimizer with just a single click in the Advanced area of the Hepsia website hosting Control Panel for any of the releases that we provide - 4, 5.2, 5.3, 5.4 and 5.5. When you go to this section, you can use a small tool that will allow you to manage the php.ini file for your account and enable or disable PHP extensions using On and Off buttons, so you will not need any previous knowledge since activating Zend Optimizer will be as simple as clicking a button. More advanced users will be able to do the same thing by placing a php.ini file with the required code in a specific domain folder. In case you need any help to activate the instrument, you can contact our tech support team at any time.
Zend Optimizer in Semi-dedicated Hosting
Zend Optimizer is installed on all servers that comprise our cluster website hosting platform, so you can use it for all of your script-driven apps with all of our semi-dedicated server packages. It will be available at all times even when you switch the PHP release for your account as our feature-rich platform allows you to select from PHP 4, 5.2, 5.3, 5.4 and 5.5. Both changing your version and activating Zend Optimizer for the new one takes a few clicks in the PHP Configuration section of the Hepsia hosting Control Panel which is used to control the semi-dedicated accounts. In addition, you can also use a different version of PHP and enable or disable Zend for every single site that you host from your account. This is possible by employing a php.ini file in a domain folder with a few lines of program code inside it. If you don't have previous experience and you are unsure how to do this, our 24/7 technical support can help you.